# "Invalid certificate file" error when browsing empty Azure Container Registry

{% hint style="info" %}
**Affected versions:** 2.13.0 to 2.17.1

**Fixed in:** 2.18.1 and above
{% endhint %}

#### Issue Description

Users are unable to browse the Azure Container Registry. The following error will appear:

```
Invalid certificate file. Ensure that the file is uploaded correctly
```

#### Cause

This issue is the result attempting to browse an empty Azure Container Registry.

#### Fix

Upgrade Portainer to 2.18.1 or above.

#### Workaround

Users will need to manually create create a repository in the Azure Container Registry and while logged in with the Access Key in Portainer, push an image. Users can then navigate back to the Registry and browse.


---

# Agent Instructions: Querying This Documentation

If you need additional information that is not directly available in this page, you can query the documentation dynamically by asking a question.

Perform an HTTP GET request on the current page URL with the `ask` query parameter:

```
GET https://docs.portainer.io/sts/faqs/known-issues/invalid-certificate-file-error-when-browsing-empty-azure-container-registry.md?ask=<question>
```

The question should be specific, self-contained, and written in natural language.
The response will contain a direct answer to the question and relevant excerpts and sources from the documentation.

Use this mechanism when the answer is not explicitly present in the current page, you need clarification or additional context, or you want to retrieve related documentation sections.
