# Client sent an HTTP request to an HTTPS server

#### Issue Description

When accessing Portainer via the web you may receive the following error message:

```
Client sent an HTTP request to an HTTPS server.
```

#### Cause

This error occurs when you attempt to access Portainer's HTTPS URL (port 9443) using the HTTP protocol:

```
http://my.portainer.url:9443/
```

This is because port 9443 only accepts the HTTPS protocol and does not accept HTTP requests.

#### Resolution

Use the HTTPS protocol in the address when accessing port 9443.

```
https://my.portainer.url:9443/
```

Alternatively if you have HTTP access enabled you can access via HTTP on port 9000:

```
http://my.portainer.url:9000/
```

<br>


---

# Agent Instructions: Querying This Documentation

If you need additional information that is not directly available in this page, you can query the documentation dynamically by asking a question.

Perform an HTTP GET request on the current page URL with the `ask` query parameter:

```
GET https://docs.portainer.io/faqs/troubleshooting/access-and-authentication/client-sent-an-http-request-to-an-https-server.md?ask=<question>
```

The question should be specific, self-contained, and written in natural language.
The response will contain a direct answer to the question and relevant excerpts and sources from the documentation.

Use this mechanism when the answer is not explicitly present in the current page, you need clarification or additional context, or you want to retrieve related documentation sections.
